Hi-tech

Android P будет блокировать приложения, созданные для Android 4.1

Android P, следующая версия мобильной операционной системы Google, по-видимому, будет блокировать приложения, созданные для Android 4.1.  Ранее в этом месяце Google опубликовал предварительный просмотр Android P Developer, и похоже, что он начнет блокировать слишком старые приложения. Согласно последним отчетам, разработчикам приложений теперь потребуется ориентироваться на минимальный уровень API 17, что совпадает с Android 4.2. Это по существу означает, что приложения под уровнем API перестанут функционировать при развертывании Android P.

Примечательно, что в предварительном просмотре Android P Developer 1 Google предупреждает пользователей, когда он видит старое приложение, он показывает сообщение:

«Это приложение было создано для более старой версии Android и может работать должным образом. Попробуйте проверить наличие обновлений или связаться с разработчиком».

Еще в декабре Google сообщил в блоге, что новые приложения, представленные в Google, будут нацелены на Android версии не старше года. Итак, начиная с Android P, минимально поддерживаемые приложения будут выше Android 4.2, а новые приложения будут нацелены на Android 8.0 Oreo или выше.

 

Добавьте «SRNSK News» в источники
Яндекс новостиGooglenews